Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #39703
    MTHMTH
    Participant

    Hi,
    When I try to install nexpose, it does not let me continue the installer. In the system requirments it shows me that port 3780 is in use.
    So how can I disable this port?

    #39734
    diegodiego
    Moderator

    Hi!
    This problem is happening cause Nexpose is starting with the system boot, this is breaking it for some reason, so the solution is to prevent it from starting at system startup, to do that do the following:
    1. Boot up Kali, login and give it sometime for the nexpose service to start.
    2. Stop the service that started with startup
    service nexposeconsole stop
    3. Remove nexpose from startup applications.
    systemctl disable nexposeconsole.service
    4. Restart, login again, now nexpose should NOT start automatically.
    5. Start nexpose manually
    service nexposeconsole start
    6. Go to http://localhost:3780, and wait for it to show you the login screen, it might get stuck at 32% for a while but give it sometime and it should work.

    Also please make sure you give Kali at least 6Gb ram (memory) if you want to use Nexpose, if you can’t then its fine, we only use nexpose in 2 lectures in the course because its designed to scan a large number if IPs, so if you needed to use it in real life then you’d probably be working for a big company that can get you a powerful computer to run nexpose.

    Hope it helps!
    Diego

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.