Tagged: 

Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • #46300
    Avatarlama.samra
    Participant

    hello
    I am trying to run my sniffer program but I get no data from the windows machine what could be the problem?

    #46306
    AvatarNikolajevZj
    Participant

    Hello,
    You need to perform the attack on the Kali machine first(on kali’s browser),in the next lectures it will be shown how to forward packets and then you will be able to sniff the data from the windows machine,I had exact same problem not so long ago.Let me know if you had a laugh on this one :D(I remember the moment when I realized it and I had a truly good time laughing).

    Best Regards,
    Nikolajev

    #46311
    diegodiego
    Moderator

    Hi Lama!

    Did your script work fine in the local host?

    Let me know.
    Diego

    #46317
    Avatarlama.samra
    Participant

    hello Diego,
    yes it do works but I still get no data or any errors

    • This reply was modified 10 months ago by Avatarlama.samra.
    #46318
    Avatarlama.samra
    Participant

    Hi Nikolajev!
    actually I did that but still not working

    • This reply was modified 10 months ago by Avatarlama.samra.
    #46345
    diegodiego
    Moderator

    Hi!
    Do you mean you can sniff data when running the script in local host? Which site are you using for testing?

    Let me know.
    Diego

    #46348
    Avatarlama.samra
    Participant

    No I can’t sniff data
    I have used many sites for testing it but no one worked, also I’m using opera browser
    And I wrote iwconfig and it showed that there is no eth0 wireless extensions it could be the problem or not?

    #46356
    AvatarNikolajevZj
    Participant

    Hi!
    It could be the problem,you should be sniffing data from your active internet interface.In case eth0 is not your active interface,check which one is by typing iwconfig
    in terminal.Are you using wireless adapter?It’s possible that you just aren’t sniffing on the right interface or did not configure the network settings in kali,cause
    when you set the NAT network in kali’s settings by default it uses simulated ethernet connection(eth0).In case you did not set up the NAT network in Kali, I think in
    the beginning of the course mr.Zaid explains and shows how to do so.But,anyway in order for the program to work you need to specify the network interface that you
    are using currently,if it’s a wireless adapter,it will show up when you type iwconfig,in my case it is wlan0.

    Let me know if this helps.
    Nikolajev

    #46357
    Avatarlama.samra
    Participant

    now I got something like this ( Accept-Language: en-US,en;q=0.5

    Accept-Encoding: gzip, deflate

    Connection: keep-alive

    Accept: */*

    User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:68.0) Gecko/20100101 Firefox/68.0

    Host: detectportal.firefox.com

    Pragma: no-cache

    Cache-Control: no-cache

    )

    #46358
    AvatarNikolajevZj
    Participant

    Is this the only thing you got?I think it isn’t bad,it proves it’s working cause it is detecting the keep alive packets.But is it something unordinary in it?
    It’s working now right?If the program is printing this stuff it shows that it runs properly,let me know if there is something else.

    #46359
    Avatarlama.samra
    Participant

    Actually I forgot to Mention that I got it when I used my browser on my linux machine not the windows I did something wrong but I don’t know what

    #46360
    AvatarNikolajevZj
    Participant

    Wait,so is there anything that’s not working,or did you figure it out cause I’m a bit confused.

    #46361
    Avatarlama.samra
    Participant

    No I don’t think it solved I Receive Receive nothing while using my browser on windows machine but I got it while using the browser on linux machine Which completely wrong

    #46362
    AvatarNikolajevZj
    Participant

    Have you used the iptables actually?Cause you know that it is necessary?You know you may have not cleared the ip tables rules or something and the packets still follow the wrong route.

    • This reply was modified 10 months ago by AvatarNikolajevZj.
    #46375
    diegodiego
    Moderator

    Hi Lama!
    It looks like you are a bit lost, the best solution is to watch the lectures again, pay attention to which commands are used while testing in the local host, I think you are using iptables for local host. And use http sites only, later on the course you’ll learn how to bypass simple https protection.

    Hope it helps!
    Diego

Viewing 15 posts - 1 through 15 (of 15 total)
  • You must be logged in to reply to this topic.