Viewing 15 posts - 1 through 15 (of 21 total)
  • Author
    Posts
  • #38448

    Zaid,
    My ngrok tunnel is not working. It is only work inside my network. It is not work in outside in my network. Why is it ?

    Regards,
    Sithum Nimlaka

    #38527
    diegodiego
    Moderator

    Hi Sithum!
    Are you sure you are using the latest custom kali image provided by Zaid? Cause I have tried this my self and in official kali linux it wont work but in custom kali it works properly.

    Let me know.
    Diego

    #38541

    Yah, I use it. But NGROK is not working.

    #38642
    diegodiego
    Moderator

    Hi Sithum!
    Can you share a screenshot of the command used to initiate the tunnel and the result please?

    How are you tesing the tunnel?

    Thanks!
    Diego

    #38646

    I use this commands,

    ./ngrok http 8080
    ./ngrok tcp 4444

    #38728
    diegodiego
    Moderator

    Hi Suthum!
    Are you testing with a backdoor? Can you tell me more about what are you doing?
    Let me know.
    Diego

    #38732

    Yah, I test it backdoor and phishing links.

    #38813
    diegodiego
    Moderator

    Hi Sithum!
    I’ve just tried it in custom kali and it’s working properly. Can you first make a test with the apache server? So just start it and then create the tunnel for port 80, see if you can reach it from the outside network.

    Let me know how it goes!
    Diego

    #38839

    Yah I do it. But it not working.

    #38917
    diegodiego
    Moderator

    Hi Sithum!

    If you are using sutom kali thne it should work outside of the local network, with official kali it will just work locally.
    So if you said you are using custom kali then are you logging ig with the root:toor credentials? or with kali:kali?

    Can you share a screenshot of the Network settings used in VirtualBox for kali?
    Have you run the command apt-get upgrade?

    Let me know.
    Diego

    #38930

    im upgraded my kali machine using apt-get upgrade command.

    #38983

    I,m get new fresh kali image provaid by zaid. I tested Ngrok in it. But i can’t access my web server using my phone.

    #38997
    diegodiego
    Moderator

    Hi Sithum!
    Yeah, if you ran apt-get upgrade then the custom changes have been undone.

    Have you started your apache server? You have to do it every time you boot kali. As I said I tested it and works for web server and backdoor using ngrok tunnel outside the network.

    Let me know.
    Diego

    #39003

    Yah i started apache server but it is not working

    #39096
    diegodiego
    Moderator

    Hi Sithum!
    But is it still working in the internal network?

    If so this is very strange, because with custom kali it should work from the outside network.
    Are you loggin in with root credentials? (root:root) or are you using kali credentials? (kali:kali)

    You haven’t run apt-get upgrade again, have you?

    Let me know.
    Diego

Viewing 15 posts - 1 through 15 (of 21 total)
  • You must be logged in to reply to this topic.