Viewing 15 posts - 1 through 15 (of 16 total)
  • Author
    Posts
  • #48559
    AverageJoeAverageJoe
    Participant

    Hello,

    I tried to install mana-toolkit via the terminal, but it couldn’t locate the file.

    So, after some research, I downloaded a zip file from Github. Was about to install it when I got the following warning:

    This is not a very good installer, it makes a lot of assumptions
    [+] It assumes you are running Kali
    [+] If you are worried about that, hit Ctl-C now, or hit Enter to continue

    I found this comment about mana-toolkit also:

    The MANA Toolkit is no longer in the repository, since this package had been superseded by newer packages.

    You should try to move on to one of the replacements of the MANA Toolkit, or you could try to install it from source by downloading from Github.

    So, is it safe to install this package?

    Thanks!

    #48562
    diegodiego
    Moderator

    Hi!
    Which was the exact website you get it from? It would be better to use custom kali for the course because it has all the needed software already installed. And yes, official kali release has dropped mana support, don’t know which software replaced it.

    Let me know.
    Diego

    #48572
    AverageJoeAverageJoe
    Participant

    Hello,

    This is the website I got it from:

    I am using the Customized version of kali.

    Thanks!

    #48692
    diegodiego
    Moderator

    Hi!
    You didn’t paste the link.
    And if you are using custom kali then mana-toolkit is already installed, why do you want to reinstall it?

    Let me know.
    Diego

    #48697
    AverageJoeAverageJoe
    Participant

    Hey,

    Yes, it is installed. Sorry about that, must of had a brain malfunction at the time.

    All is well now!

    Thanks

    #48812
    diegodiego
    Moderator

    Hi!
    It’s ok, cool you got it!
    Diego

    #49053
    Avatarmanikhan001
    Participant

    Dear All,

    i am trying to run Mana-Tool “start-nat-simple.sh” i am getting below error, kindly need your support.
    Configuration file: /etc/mana-toolkit/hostapd-mana.conf
    nl80211: Could not configure driver mode
    nl80211: deinit ifname=wlan0 disabled_11b_rates=0
    nl80211 driver initialization failed.
    wlan0: interface state UNINITIALIZED->DISABLED
    wlan0: AP-DISABLED
    hostapd_free_hapd_data: Interface wlan0 wasn’t started Hit enter to kill me

    Regards,
    Imran

    #49109
    diegodiego
    Moderator

    Hi!
    Can I see the result of ​ifconfig ​BEFORE starting mana, and the contents of ​start-nat-simple.sh ​and ​hostapd-mana.config ​please? And the results of the command iw list.

    Can I also see a screenshot of Kali’s network settings please?
    So just right click the Kali machine in Virtual Box >> Setting >> Network, take a screenshot and post it here please.​​​
    Also can you please give me the exact model of your adapter?

    Thanks!
    Diego

    #49327
    Avatarmanikhan001
    Participant

    Hi bro,

    kindly see below pics for all requirement you asked, sorry for uploading in gdrive here i did not find option for attaching screenshot.

    https://drive.google.com/drive/u/0/folders/1i-5SQ6iGea54mES91HkPbTsUrL_o-Scq

    i am using Alfa adapter Model: AWUS036H

    #49351
    diegodiego
    Moderator

    Hi!
    I couldn’t access the drive, I already requested you for permission.

    Greetings!
    Diego

    #49355
    Avatarmanikhan001
    Participant

    done already , kindly access now

    #49379
    diegodiego
    Moderator

    Hi!
    Hostapd file in not complete, you just shared the header, also I’ll recommend to use custom kali for the course sake and if you want to use anyother kali version for your own work is ok. This because you’ll need to be roor user to run this attack properly and using custom kali will also have the proper version and tools installed on it.

    Also you didn’t mentioned you adapter model, can you share a screenshot with the results of iw list?

    Thanks!
    Diego

    #52049
    PierpaoloPierpaolo
    Participant

    hello I have a question.
    when i use mana-toolkit i don’t have to use tools that allow to bypass the https protocol?

    #52068
    diegodiego
    Moderator

    Hi!
    Yes, if you want sniff from https sites you’ll need to downgrade the connection as well, the only difference is that you don’t have to use the arp.spoof module as you are the MITM already.

    Greetings!
    Diego

    #52076
    PierpaoloPierpaolo
    Participant

    ok, only when I use mana toolkit, it doesn’t make me use bettercap, because rightly, the wifi adapter is in AP mode, how can I use bettercap using mana-toolkit too?

    good bye Pierpaolo

Viewing 15 posts - 1 through 15 (of 16 total)
  • You must be logged in to reply to this topic.