Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #29240
    austintuleyaustintuley
    Participant

    Zaid,

    when I run the original program built in this lecture and only scan for .1, I get this:
    ARP who has 10.0.2.1 says 10.0.2.4
    when i scan for 10.0.2.1/24 I get this:
    ARP who has ?? says ??

    The code is identical to your code but I can’t seem to run this code on every IP address. It is only working for one IP at a time. I am building in Pycharm and running the file in terminator.
    I have tried python as well as python3 and continue to get the question marks.
    This is using arp_request rather than the original arping!

    Thanks again for your help.

    #29261
    austintuleyaustintuley
    Participant

    There seems to be a problem with the module scapy.

    The module does not seem to be functioning properly whether I use pycharm in kali in virtual box or if i am using vs code in a full kali install. I have tried importing scapy.all as in your videos as well
    as tried
    from scapy.all import *
    As soon as I want to scan an entire range such as “10.0.2.1/24” the app breaks. The only way I can get any output is to target a single IP such as 10.0.2.1
    Also, I have verified my full install will ping this windows PC when running the network_scanner.py file from my full kali install as long as I only use this PC’s IP. Again, the problem only seems to happen when scanning a range.
    Is there an update or different way to import scapy?
    I really enjoy your courses and teaching style and hope there is a quick/efficient resolution.
    Thanks again for your help.

    #29268
    austintuleyaustintuley
    Participant

    Another thing that should be noted, if I try to run the program in either pycharm or vscode I get an error saying module not found.

    With that said, if I run the script from the terminal it will run as long as I only search for one IP address, rather than a range, as stated above. I have also tried with python3 in the shebang as well as just python. I have also run the script with python as well as python3. The script always works as long as I am not scanning a range.

    #29271
    AvatarZaid Sabih
    Moderator

    Hey austintuley,
    yeah this is normal because Pycharm uses its own interpreter not the system interpreter, therefore when you install libraries using pip it’ll only get installed to the default interpreter that is used by the operating system.

    #29276
    austintuleyaustintuley
    Participant

    Have you seen the entire app break when trying to scan the entire range? I absolutely do not mind running from the terminal, in fact, I prefer it as well, but I would like the network_scanner to run the entire range for the network.

    I receive this line at the end of the Traceback:
    AttributeError: ‘NoneType’ object has no attribute ‘split’

    I am running Python 3.7.5

    #29650
    austintuleyaustintuley
    Participant

    Any idea what would cause scanning the entire range to throw an error? I have searched google and stackoverflow thoroughly with no luck. As long as I scan for a specific IP the program works fine, just not when scanning the range. I’m stuck at this point as I will not move on to the next lecture without being able to complete this one correctly.

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.