Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #34453

    When I click the link to download tails, I receive a message saying “This site can’t provide a secure connection. tails.boum.org uses an unsupported protocol. ERR_SSL_VERSION_OR_CIPHER_MISMATCH”. I looked up how to fix this and found a link detailing ways to fix it, so I tried the following methods suggested:
    Did an SSL check on Qualys SSL Labs. SSL certificate judged to be fine. No certificate name mismatch.
    Tried clearing SSL state. Didn’t fix the issue.
    Checked TLS version. Link suggested that it should be at least 1.2, preferably 1.3. It is 1.2.
    Temporarily disabled antivirus software. Didn’t fix the problem.
    How else could I fix this?

    #34496

    It is really hard for me to debug you issue this way. Please take a screenshot of the error message(https://imgbb.com) and post it here.

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.