This topic contains 1 reply, has 2 voices, and was last updated by Avatar Zaid Sabih 1 year, 1 month ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #14643
    Avatar
    artuk
    Participant

    Hello again Zaid, I would appreciate advice re the following errors.
    dnsmasq -C /root…..etc.conf gives error message
    failed to create listening socket for port 53 address already in use
    I did flush iptables including stopping network-manager and using netstat -utnlp I get the PID /dnsmasq and by running kill (PID number) and restarting dnsmasq -C /root…..etc.conf this now works
    But having to kill the PID which is running everytime I run the dmasq command is obviously not practical. Have found lots of info online but nothing that solves this.
    Any suggestions please.

    and after starting dnsmasq I run the similar command for hostapd but get error invalid/unknown driver nl80211
    1 error found in configuration file /’file location’ fialed to initialise service
    again there is lots of info about this error online but none of the suggestions helped to solve this.
    any suggestions please
    Thanks and regards
    Arthur

    #14646
    Avatar
    Zaid Sabih
    Participant

    Hello Arthur,

    Yeah this dnsmasq issue is annoying, not sure what you tried so far but the way I usually do it is just kill it by doing
    killall dnsmasq

    Might not be the best way of doing it but works fine.
    ————-
    As for the other issue, have you tried physically disconnecting the wireless adapter and then connecting it again?

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.