Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #47381
    Avatarbull
    Participant

    Hi, could you please help? I’ve installed Windows 10 and Kali as virtual machines. I’m running Backbox as my main O/S. I have selected NAT in Virtual Box settings however when I enter the command “ifconfig” in terminal I can only see three interfaces –

    enp0s25:
    lo:
    proton0:

    None of which are my VMs. Can you please help?

    Thank you

    #47387
    diegodiego
    Moderator

    Hi!
    Where are you running the ifconfig command? Is it in kali?

    Can you show the results of:
    ifconfig and route -n in kali
    ipconfig in windows
    Can you share a screenshot of the Network settings used in VirtualBox for both machines?

    Thanks!
    Diego

    #47389
    Avatarbull
    Participant

    Hi Diego, thanks for replying!

    I ran ifconfig from my main O/S – backbox. But I’ve done it from Kali VM too (screenshot below)

    kali-ifconfig
    win10-networksettings
    kali-networksettings
    win10-VMscreenshot
    win10vmipaddress
    netdiscover-results
    route-n-kali-VM

    Thank you!

    #47440
    diegodiego
    Moderator

    Hi!
    It looks like you have selected NAT option instead of NAT Network, both options are present and it can be confusing. You need to attach the machines to the same NAT Network.

    Hope it helps!
    Diego

    #47442
    Avatarbull
    Participant

    Hi Diego,

    Thanks for that. It appears using zenmap in backbox doesn’t show the other machines but using netdiscover in kali VM does pick them up.

    Thanks again!

    #47455
    diegodiego
    Moderator

    Hi!
    Cool you got it! What do you mean by backbox?

    Let me know.
    Diego

    #47532
    Avatarbull
    Participant
    #47533
    diegodiego
    Moderator

    Hi!
    Yeah, your main OS will not communicate with the virtual machines or viceversa, that’s normal. So they won’t appear in the results of netdiscover.

    Greetings!
    Diego

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.