• This topic has 5 replies, 3 voices, and was last updated 1 year ago by diegodiego.
Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #46507
    joeljoel
    Participant

    My antivirus is blocking the connection with a website when running apt-get update on Kali VM due to a Trojan being detected. Is this normal and what is the way to bypass the host machine AV when using Kali on VirtualBox? Also, can my host machine be compromised in any way when using the VM?

    #46584
    s4mu_s4mu_
    Participant

    This shouldnt happen as the vm has no connection to the host machine. It´s like a totally different computer.
    anyways dont listen to me wait for a moderator to answer you as they will surely know more about the matter.
    greetings

    #46585
    joeljoel
    Participant

    Thanks s4mu_. Yes, that’s what I thought. Whatever I do on the VM shouldn’t have anything to do with the host. I also tried accessing the url directly from the browser on the VM with the same results. Anyway, there should be an explanation and fix for this. Will wait for the moderator’s response.
    Thanks

    #46591
    diegodiego
    Moderator

    Hi!
    Are you sure you are using the latest custom kali image provided by Zaid? It’s important!

    Sometimes defender detects kali’s repositories as malicious, it will also depend on the repositories you have in the sources.list file, if you are using custom kali and haven’t modified such file then it’s safe to disable defender or any AV and try it again.

    Greetings!
    Diego

    #46595
    joeljoel
    Participant

    Hi Diego

    Yes, I’m using the latest image of the custom Kali. I just found out that using a VPN solved the issue without having to disable the AV. The Trojan was detected from a specific local mirror website which was not used when updating using a different ip address.

    Cheers
    Joel

    #46640
    diegodiego
    Moderator

    Hi!
    Cool you got it!
    Diego

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.